I tried building Samba-4.1.12 without Avahi but it is still required ...

Richard Sharpe realrichardsharpe at gmail.com
Tue Nov 11 08:45:46 MST 2014

On Tue, Nov 11, 2014 at 7:40 AM, Rowland Penny <repenny241155 at gmail.com> wrote:
> On 11/11/14 15:18, Richard Sharpe wrote:

Added samba-technical back.

>> On Tue, Nov 11, 2014 at 4:28 AM, Rowland Penny <repenny241155 at gmail.com>
>> wrote:
>>> On 10/11/14 22:17, Richard Sharpe wrote:
>>>> Hi folks,
>>>> I tried ./buildtools/bin/waf configure --disable-avahi but the
>>>> binaries are still linked with libavahi etc.
>>>> What do I need to do?
>>> Have you tried '--enable-avahi=no' ?
>> Yeah, but that is not the syntax. You get an error message when you do
>> that.
>> The problem is deeper than that. It seems that a bunch of different
>> libraries need two damn avahi libraries ... and I haven't figured out
>> how to get rid of them yet.
> OK, I was basing my answer on './configure --help', which produces (amongst
> everything else) this:
>    --enable-avahi
>             Build with avahi support (default=yes)
> which to me means that the default is '--enable-avahi=yes', so from that I
> got '--enable-avahi=no'. You have found that this doesn't work, so to me
> this means that there is a bug in './configure --help', shouldn't the
> message be in the form of:
> --enable-avahi
>             Build with avahi support (this is the default and does not need
> to be added)

Yeah, that's true. It should probably spell out how to disable as well.

Richard Sharpe

More information about the samba-technical mailing list