samba-tool ldapcmp and rodc and instanceType attribute

Denis Cardon denis.cardon at
Mon Nov 10 13:36:05 MST 2014

Hi all,

I was doing some cleansing of replicated DC recently, I tried a ldapcmp 
between the central DC and a remote RODC. samba-tool ldapcmp already 
ignore some attribute, but I think it should also ignore the 
instanceType attribute.

     Difference in attribute values:
         instanceType =>

0x00000004 value means that the entry is read/write on that directory, 
which is indeed not the case on the RODC (so the reported error is 
actually a correct case)

Digging a little more in my RODC, I realized that many DNS entries has a 
0x00000004 value... and only recently created entries has the 0x00000000 

This is probably a former bug that has been solved I guess. Do you all 
advise to make a full sync of the remote partition when one upgrade to a 
newer version to cleanup this kind of issue?



Denis Cardon
Tranquil IT Systems
Les Espaces Jules Verne, bâtiment A
12 avenue Jules Verne
44230 Saint Sébastien sur Loire
tel : +33 (0)

More information about the samba-technical mailing list