ENOSPC returned when trying to expand a TDB file because it runs into the next VM segment and has a large dead record

Richard Sharpe realrichardsharpe at gmail.com
Mon Mar 3 12:09:37 MST 2014

On Mon, Mar 3, 2014 at 11:03 AM, Volker Lendecke
<Volker.Lendecke at sernet.de> wrote:
> On Mon, Mar 03, 2014 at 10:35:10AM -0800, Richard Sharpe wrote:
>> Hi folks,
>> We are running into tdb problems where tdb_expand_file is getting
>> ENOSPC when trying to expand the file. The error is actually happening
>> during the pwrite.
> Is this ENOSPC real, i.e. is /usr/local/var/locks on a full
> filesystem? I'm not sure that tdb handles ENOSPC really
> gracefully in the sense that we never generate unexpected
> tdb records. Possibly that large dead record is not a real
> dead record but space that we tried to allocate from disk
> but could not.
> How much space do you have left on /usr/local/var/locks?

That's a good question. It seems like we have more than the 8kiB that
was complained about, but the error message does not tell us how much
we tried to expand the tdb by :-(

We subsequently dumped core into the same file system, so there was
some space available. We currently have several hundred megabytes
available, but that file shows a large dead record, possibly bogus.

Richard Sharpe

More information about the samba-technical mailing list