lib_3p system

Ira Cooper ira at
Thu Jul 17 08:24:22 MDT 2014

On Thu, Jul 17, 2014 at 10:00 AM, Michael Adam <obnox at> wrote:

> On 2014-07-17 at 15:45 +0200, Kai Blin wrote:
> >
> > >>>>lib_3p stands for "Libraries, Third Party." "external" is a bit too
> vague
> > >>>>for this use.  I really want an exact meaning.
> > >>
> > >>lib/ is for the first party libraries.
> What are second party libraries, btw?

First Party:You.
Second Party: Others in the licensing agreement.  (This is none in our
Third Party: All others.

Rarely if ever have I seen second party called out.  Usually, you'd call
them our by name.  Third Parties are usually lumped together.  (or they'd
be second!)

> >It's for both, at least not at the moment.
> I think we should have a clear separation, directory-wise,
> between libraries/components that we maintain in-tree
> and libraries/componentes that we have pulled into the
> tree and don't maintain ourselves.

+1.  That is the intent of this change.  Even if all the components are not
picked up at this time.

>  > >If you'd like to change that, and have the third party stuff somewhere
> > >else, can we please call that "third_party/" ? "Libraries" is also
> > >a misleading name since some of the third party stuff we bundle are
> > >things like Python modules.
> >
> > To be honest, I don't care much about lib/ or not, but _3p was
> > drastically non-obvious to me. The subject looked like the patches
> > were about a possibly vendor-specific file system or the like
> > (storage products like 3par would come to mind).
> >
> > It's not like the few extra characters cost a lot of bandwidth :)
> Same here, I was puzzled about 3p until I read down in the thread. :-)

Ok, request to change name ACKed.  It takes a few requests for me to ACK a
name change in particular because they tend to be bike shed discussions.
Once I can see a clear consensus, and reasons from more than one person...
I'll make a change.

- I think it should _not_ go under ./lib/ (see above).
> - My current vote would be for "./thirdparty/

We are inconsistent with what we call things as far as using a '_', '-', or
nothing at all.  Alas, that is a bit of a pain.

I'm going to be arbitrary, and say we all lose.  third-party it is!

The reason behind the - is quite simple... samba-third-party-4.2.10.tar
just reads right.

Due to the name change I'll restructure the commits, to be more clear,
though it'll result in much more churn, the goal of the changes will be
highlight the build system changes to support the changes.  Review should
be much easier even if you can't deal with the large moves etc.

I'll send out a new topic with the new branch + third-party repo.  (which
should be lib_3p.git moved.)


-Ira / ira at

More information about the samba-technical mailing list