Problem with upgrade from Samba 3 to Samba 4 AD

sompassiti sompassiti at yahoo.Fr
Tue Jul 8 01:13:48 MDT 2014


I struggle since a cup of day with my Samba 3 NT domain to Samba 4 AD
migration. I firt have  a probleme of duplicate SID and GID but i fix it
this by changing all of theses manually. After that i faced a problem of
users and groups sharing the same CN. I fix it too manually by changing the
name of users or groups. I also had to delete some computers from the ldap
database because it says that they can't be found. After all that i actually
face a wall!! When i run my migration command:

" # ./samba-tool domain samba3upgrade --dbdir=/root/sambaNT/
--use-xattrs=yes --realm= --dns-backend=SAMBA_INTERNAL
/root/sambaNT/smb.conf "

i got the same error message:

*ERROR(<type 'exceptions.KeyError'>): uncaught exception - 'No such element'
line 175, in _run
    return*args, **kwargs)
line 1318, in run
    useeadb=eadb, dns_backend=dns_backend, use_ntvfs=use_ntvfs)
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/",
line 903, in upgrade_from_samba3
    add_group_from_mapping_entry(result.samdb, g, logger)
  File "/usr/local/samba/lib64/python2.6/site-packages/samba/",
line 265, in add_group_from_mapping_entry
    str(groupmap.sid), groupmap.nt_name, msg[0]['sAMAccountName'][0])*

I thought it was a problem of python version and i installed python 3.3.5
but still have the issue.
I verified that all required libraries was installed and that my OS was up
to date.

here is my configuration:

Source server (NT domain): CentOS 5.6	OpenLdap version 2.3.43-12.el5_6.7 and
Samba3x version 3.5.4-0.70.el5_6.1
Target Server: CentOS 6.4 with Samba 4.1.8.

Please HELP!!!

View this message in context:
Sent from the Samba - samba-technical mailing list archive at

More information about the samba-technical mailing list