[PATCH] Rename variables used by loadparm
garming at catalyst.net.nz
Mon Jan 6 20:34:41 MST 2014
On 24/12/13 20:21, Andrew Bartlett wrote:
> On Tue, 2013-12-24 at 17:21 +1300, Garming Sam wrote:
>> (resend from correct account)
>> This set of changes renames a large number of variables used by loadparm
>> in an effort to simplify and unify the naming scheme. This should be
>> helpful for potential future work in auto-generating param_functions.c
>> and param_table.c from the xml-documentation.
>> We skipped domain_master and printername this time around due to the
>> automated script causing issues. Andrew Bartlett and I have visually
>> inspected every one of these patches.
>> Please review and push. It's on top of metze's master4-schannel-ok
>> branch to avoid conflicts with his pending work.
> Thanks Garming!
> We spent the time this afternoon writing some global-replace scripts to
> handle this safely, one change per commit. They worked very well, but
> we skipped domain_master and printername for now because some of the
> automatic renames were not as tidy as we would have liked. The rest
> are, with only a couple of exceptions, all from the automated script and
> so are all consistent.
> The variable in the global or service structure is now always the name
> of the lp_ and lpcfg_ function (we don't need two different identifiers
> Andrew Bartlett
I've just put all the changes into a repository as the patch was too big
for the list.
More information about the samba-technical