Setting up CTDB on OCFS2 and VMs ...

Martin Schwenke martin at
Tue Dec 16 16:45:41 MST 2014

On Tue, 16 Dec 2014 21:12:12 +0000, Rowland Penny
<repenny241155 at> wrote:

> I ran the ping_pong test this morning, following the wiki page and as 
> far as I could see it passed all tests.

When I run "ping_pong /clusterfs/test.dat 3" on 1 node of a 2 node OCFS2
cluster, I see a very high locking rate - in the 10000s.  When I run it
on another node I see the same high locking rate and I don't see the
rate drop on the 1st node.  That's a fail.

This is on a cluster where I haven't worked out the extra steps to get
lock coherence.

> I have come to the conclusion that you need to be a CTDB dev to set CTDB 
> up, only they seem to have ALL the information required.

Sorry, but that line is starting to grate.  I'm concerned that
statements like this are likely to put people off using CTDB.  There are
many non-CTDB-devs out there running CTDB with other cluster

When the CTDB recovery lock is configured then CTDB has a hard
requirement that the cluster filesystem *must* provide lock coherence.
So the problem you have is a lack of lock coherence in OCFS2.

I am a CTDB dev.  I haven't yet got OCFS2 working, partly due to lack
of time to figure out which pieces I'm missing.  I have a simple recipe
that gets me to a similar point to where you are at and I haven't even
looked at corosync.  At some time I will try to go through Richard's
instructions and try to distill out the part that adds lock coherence.

I was confused by the ping pong test results so I tried to clarify the
documentation for that test.

It seems like OCFS2 is stupendously difficult to setup with lock
coherence.  This is not CTDB's fault.  Perhaps you need to be an OCFS2
dev to setup CTDB with OCFS2?  ;-)

> I absolutely give up, I cannot make it work, god knows I have tried, but 
> I just cannot make it work with the information available. I can find 
> bits here and bits there, but there still seems to be something missing, 
> or is it just me. Debian 7.7, Pacemaker, Corosync and Ocfs2 work OK, it 
> is just when you try to add CTDB.

If all those other things provided lock coherence on the cluster
filesystem then CTDB would work.  So adding CTDB makes you notice the
problem but CTDB does not cause it.  :-)

peace & happiness,

More information about the samba-technical mailing list