Preliminary success with OCFS2 and CTDB 2.5.4

Richard Sharpe realrichardsharpe at
Tue Dec 2 17:20:27 MST 2014

On Tue, Dec 2, 2014 at 4:14 PM, Amitay Isaacs <amitay at> wrote:
> Hi Richard,
> On Wed, Dec 3, 2014 at 8:38 AM, Richard Sharpe <realrichardsharpe at>
> wrote:
>> Hi folks,
>> Despite the vehement statements by some people on this list, I have
>> gotten the ctdb ping_pong test to work with OCFS2 and CTDB 2.5.4 on
>> CentOS 6.6.
>> On one member:
>>     [root at ocfs2-1 rsharpe]# ping_pong -rw /shared/ctdb/reclock 3
>>     data increment = 1
>>     ^C  3079 locks/sec
>>     [root at ocfs2-1 rsharpe]# ping_pong -rw /shared/ctdb/reclock 3
>>     data increment = 2
>>     ^C   277 locks/sec
>> One the other member:
>>     [root at ocfs2-2 ~]# ping_pong -rw /shared/ctdb/reclock 3
>>     data increment = 1
>>     data increment = 2
>>     data increment = 1
>>     ^C  3150 locks/sec
>> The last lock rate was after I stopped the ping_pong command on the
>> first member. I was getting around 270 when ping_pong was running on
>> both nodes.
>> Do those locking rates look reasonable?
>> Now to get ctdb and Samba really working.
>> (Details of what I had to do available upon request)
> This is really great.  Martin and I spent some time trying to make OCFS2
> work on RHEL6 without much success.  The main problem was getting OCFS2
> kernel modules on RHEL6.  We tried building the OCFS2 kernel modules from
> source, but that did not work.  Any comments on how to make it work on RHE6
> are much appreciated. Our plan is to integrate OCFS2 in autocluster, so we
> can build samba cluster with OCFS2 for automated testing.

I would imagine that the RPMs I used from Oracle would work, but
someone will have to fix the issue with ocfs2_controld.cman.

I will try to document the steps I took in more detail, but briefly:

1. I installed CentOS 6.3 and upgraded to CentOS 6.6. These should be
exactly the same as RHEL 6.3 and 6.6. I haven't tried with CentOS
7/RHEL 7.

2. I installed Oracle's UEK kernel. Not sure how to do it without doing that.

3. I had to build the ocfs2-tools module and although it failed, it
gave me ocfs2_controld.cman so I was happy.

Maybe we can talk some more about this ...

> With GPFS, ping_pong -rw test gets around 35,000-40,000 locks/sec on a two
> node cluster when running on both nodes. Running on a single node gives
> around 120,000 locks/sec.

Heh, real hardware, eh, rather than the VBox VMs I was using. Still,
that is awesome.

Richard Sharpe

More information about the samba-technical mailing list