cthon failure

Jeremy Allison jra at samba.org
Mon Aug 25 18:10:33 MDT 2014

On Mon, Aug 25, 2014 at 07:05:53PM -0500, Steve French wrote:
> I just tried it on recent Samba (from about a week ago) with the same results
> Version 4.2.0pre1-GIT-47e7440
> and also
> Version 4.1.6-Ubuntu
> If "store dos attributes = yes" (on by default in Ubuntu) is in smb.conf
> then the following fails
> mount -t cifs //someserver/someshare /mnt
> touch /mnt/newfile1
> chmod 0000 /mnt/newfile1
> stat /mnt/newfile1   (mode displays as expected)
> rm /mnt/newfile1  (fails with access denied)
> if the identical scenario is tried with "store dos attributes = no" in
> smb.conf then it works
> mount -t cifs //someserver/someshare /mnt
> touch /mnt/newfile2
> chmod 0000 /mnt/newfile2
> stat /mnt/newfile2  (mode displays as expected)
> rm /mnt/newfile2   (delete works), and also removing the newfile1
> created above also works)
> rm /mnt/newfile1 (also works)
> Details:
> posix unlink (set path info) fails with access denied/status cannot
> delete, as does subsequent smb delete.   Attempts to clear the
> readonly bit also fails with access denied
> The chmod 0000 causes Samba server to set the read-only dos attribute
> in the failing case

As I said - can't reproduce here so obviously reporting
the same thing I already used to reproduce isn't going to help :-).

Can you get me YOUR ENTIRE smb.conf, debug level 10 log,
wireshark trace of the activity please.

Log a bug and attach them - easiest way to track.

More information about the samba-technical mailing list