SAMBA4 Name Server Record

Michael mlstarling31 at
Sat Aug 16 06:33:55 MDT 2014

Thiago, thanks for sharing your experience. It's nice to know I'm not the only one facing this issue.  

Unfortunately google is failing me so hopefully someone has come across a fix.


From: thiagocmartinsc at
Date: Sat, 16 Aug 2014 05:16:07 -0300
Subject: Re: SAMBA4 Name Server Record
To: mlstarling31 at
CC: samba-technical at

Hello Mike,
I think I'm facing the very same problem with Samba 4.1.6 on Ubuntu 14.04.1.
Master =

IP = NS entry = yes
Joined "ubuntu-ad-2" into "*", as a secondary DC, it did not have a NS entry.

Joined "ubuntu-ad-3" into "*", as a secondary DC, it did not have a NS entry.

The command "host -t SRV" shows all Domain Controllers but, the command "dig @" does not show "ubuntu-ad-2 | 3" under "AUTHORITY SECTION".

Weird is that, later, to test, I joined a W2K8 R2 "win-ad-1", as a secondary DC (using dcpromo, with Global Catalog, DNS Server and etc), and it appeared as a NS for the domain(s)! After a few errors... "win-ad-1" becomes authoritative but ubuntu-ad-2|3 doesn't.

Regular Domain Members (smbd fileservers, desktops) and its DNS entries are working just fine, including support for Disjoint Namespaces and reverse DNS, for both IPv4 and IPv6.

- Thiago

On 15 August 2014 23:27, Michael <mlstarling31 at> wrote:

I'm using the latest samba build (4.1.11) and I've setup a Domain two Domain  Controllers,  however when the second Domain Controller joined the domain a HOST(A) record was created automatically but there was no Name server record added to DNS for the second DC.

Hello all,

I'm trying to add a second NS record for my 2nd DC but can't seem to get it done.

I've tried a couple of syntaxes based on the samba-tool and it command appears to complete successfully but the DNS record doesn't show up then DNS breaks and I have to delete the record to get things working again.

Initial DC that has a NS record


Second DC that joined without an NS record




My command syntax: ( This completes successfully but breaks DNS)

samba-tool dns add adldap1.samba4.lott samba4.lott adldap1.samba4.lott NS adldap2.samba4.lott

I also tried swapping the servers in case I has the syntax wrong..

samba-tool dns add adldap1.samba4.lott samba4.lott adldap2.samba4.lott NS adldap1.samba4.lott

I've also tried adding a second NS record using  the Windows DNS snap-in but I get validation error.

Note that all DNS queries are working fine for all nodes from all nodes.

What am I missing here?



More information about the samba-technical mailing list