SAMBA4 Name Server Record

Michael mlstarling31 at
Fri Aug 15 20:27:14 MDT 2014

I'm using the latest samba build (4.1.11) and I've setup a Domain two Domain  Controllers,  however when the second Domain Controller joined the domain a HOST(A) record was created automatically but there was no Name server record added to DNS for the second DC.

Hello all,
I'm trying to add a second NS record for my 2nd DC but can't seem to get it done.

I've tried a couple of syntaxes based on the samba-tool and it command appears to complete successfully but the DNS record doesn't show up then DNS breaks and I have to delete the record to get things working again.

Initial DC that has a NS record

Second DC that joined without an NS record


My command syntax: ( This completes successfully but breaks DNS)

samba-tool dns add adldap1.samba4.lott samba4.lott adldap1.samba4.lott NS adldap2.samba4.lott

I also tried swapping the servers in case I has the syntax wrong..

samba-tool dns add adldap1.samba4.lott samba4.lott adldap2.samba4.lott NS adldap1.samba4.lott

I've also tried adding a second NS record using  the Windows DNS snap-in but I get validation error.

Note that all DNS queries are working fine for all nodes from all nodes.

What am I missing here?



More information about the samba-technical mailing list