Error "in dfs path \machinename\export1 is not a dfs root."

sandeep nag sandeepnagamalli at
Sun Aug 3 20:56:36 MDT 2014

A directory was exported from samba server, samba server is added to a
domain. (We use Likewise with Samba for AD support.). From Windows client,
administrator as configured  'DFS manager' to have the above export
'export1'. After doing this, permissions(security descriptor) on the
export1 are lost and user is unable to read/write/open into the export.
Right-click on the export from client shows Security descriptor with only
one entry 'S-1-5-113' with full permission, where as a list of around 5 to
6 ACLs are expected with an 'administrator' user to have full permissions.

Note: We are not seeing this issue if we create an export with some other
name 'export2' or 'test' etc.

In Samba logs I see the following error:
"in dfs path \machinename\export1 is not a dfs root."

1. On seeing the above error, I guessed the problem could be with the DFS
manager cache cleanup issue and deleted the entry 'export1' from DFS
manager, stopped DFS services, deleted the export on samba server and
recreated with the same name. Again I see the same error and export1 having
no permissions to access.

2.One of our engineer also tried, adding an entry 'msdfs root = no', 'msdfs
root = yes' , but still see the same error.

Please help me in narrowing down the issue, whether this is some cache
clean-up issue? (or) something else?


More information about the samba-technical mailing list