[PATCH] Storing the ACL control flags with vfs gpfs.

Jeremy Allison jra at samba.org
Fri Apr 4 16:43:17 MDT 2014


On Fri, Apr 04, 2014 at 07:05:25PM +0200, Alexander Werth wrote:
> On Wed, 2014-03-26 at 05:20 +0100, Alexander Werth wrote:
> > On Mon, 2014-03-24 at 13:21 -0700, Jeremy Allison wrote:
> > > On Fri, Mar 21, 2014 at 03:07:44PM -0700, Christof Schmitt wrote:
> > > > On Fri, Mar 21, 2014 at 04:47:39PM +0100, Alexander Werth wrote:
> > > > > diff --git a/source3/modules/nfs4_acls.c b/source3/modules/nfs4_acls.c
> > > > > index 774c40e..3edb321 100644
> > > > > --- a/source3/modules/nfs4_acls.c
> > > > > +++ b/source3/modules/nfs4_acls.c
> > > > > @@ -49,6 +49,7 @@ typedef struct _SMB_ACE4_INT_T
> > > > >  typedef struct _SMB_ACL4_INT_T
> > > > >  {
> > > > >  	uint32	magic;
> > > > > +	uint16_t	controlflags;
> > > > >  	uint32	naces;
> > > > >  	SMB_ACE4_INT_T	*first;
> > > > >  	SMB_ACE4_INT_T	*last;
> > > > > @@ -218,6 +219,7 @@ SMB4ACL_T *smb_create_smb4acl(TALLOC_CTX *mem_ctx)
> > > > >  		return NULL;
> > > > >  	}
> > > > >  	theacl->magic = SMB_ACL4_INT_MAGIC;
> > > > > +	theacl->controlflags = SEC_DESC_SELF_RELATIVE;
> > > > >  	/* theacl->first, last = NULL not needed */
> > > > >  	return (SMB4ACL_T *)theacl;
> > > > >  }
> > > > > @@ -288,6 +290,25 @@ uint32 smb_get_naces(SMB4ACL_T *theacl)
> > > > >  	return aclint->naces;
> > > > >  }
> > > > >  
> > > > > +uint16_t smb_get_controlflags(SMB4ACL_T *theacl)
> > > 
> > > smb_get_controlflags/smb_set_controlflags is too generic a name I'm afraid for
> > > what this code does.
> > > 
> > > Can you change it to:
> > > 
> > > 	uint16_t smb_get_nfsv4acl_controlflags(SMB4ACL_T *theacl)
> > > 	bool smb_set_nfsv4acl_controlflags(SMB4ACL_T *theacl, uint16_t controlflags)
> > > 
> > > Instead please ? I'll re-review once you've made that change.
> > 
> > Thanks. I've changed the names to:
> > smbacl4_get_controlflags() and smbacl4_set_controlflags().
> > That's the typical prefix used for other nfs4acls functions.
> 
> Hi all,
> 
> I'm bumping this patch since it's still pending a second review and
> comment on the function name.
> The smbacl4_ prefix is typically used by the other functions in the
> nfs4acls module that also deal with the SMB4ACL_T struct.

OK, LGTM - pushed to autobuild (although I can't
test the gpfs-specific parts).

Jeremy.


More information about the samba-technical mailing list