vfs_shadow_copy2 configuration

Michael Adam obnox at samba.org
Thu Sep 26 21:40:50 CEST 2013

Hi Dan,

please apopogize the delay:
Your mail has somehow slipped my attention.

On 2013-09-08 at 18:01 +0200, Dan Cohen1 wrote:
> Hi Michael,
> I had another issue with shadow copy2: even when using relative paths 
> restoring of files from the snapshots failed. 
> Windows was giving me error messages like this one: "Could not find this 
> item, This is no longer located in 
> \\<machine_name>\<share_name>\<share_name>. Verify item's location and try 
> again". Obviously the second <share_name> in the giving path is needless. 
> I started to investigate it and kind of arrived to a dead end. So I 
> decided to take your branch with your work on shadow copy2 vfs to see if 
> it solves my issues and to give you some feedback as you asked me.
> The good news are that when eventually I've succeeded to apply your 
> changes to vfs_shadow_copy2.c everything worked as expected.

> I applied the changes on top of branch based on samba 4.0.4. We use GPFS 
> as the file system and I tried two configurations for shadow copy2:
> Configuration 1:
> shadow:snapdir = <absolute_path_to_snapshot_directory>
> shadow:basedir= <our base dir>
> shadow:snapdirseverywhere= no
> and configuration 2:
> shadow:snapdir = .snapshots
> shadow:snapdirseverywhere = yes
> both configurations worked perfectly, previous versions were presented by 
> the windows tab and files/directories were restored correctly from the 
> previous versions using the windows interface.
> So at least for the configurations I tested your work seems to solve the 
> issues, including absolute path issue.

That is really good news, indeed!
Thanks for the feed-back.
I got delayed yet again, but I will polish and publish the
changes soon.

> Only problem was that I couldn't really fetch/clone your git repository to 
> my host, so I had to manually merge the file vfs_shadow_copy2.c and fix 
> some mismatches with my branch (using copy_smb_filename instead of 
> cp_smb_filename).
> When I'm trying to clone/fetch your branch I'm getting the following error 
> message:
> -----------------------------------
> dancoh at host176:/local/dancoh$ git clone 
> http://gitweb.samba.org/obnox/samba/samba-obnox.git
> Cloning into 'samba-obnox'...
> error: Unable to find bc07864b77e10f1f231f9177ba168c222d0c555d under 
> http://gitweb.samba.org/obnox/samba/samba-obnox.git
> Cannot obtain needed object bc07864b77e10f1f231f9177ba168c222d0c555d
> while processing commit d65db48db51006a766a8f58a53e7c1022e6c630c.
> error: Fetch failed. 
> -------------------------------------
> I tried several times, from several machines,  with no success. Cloning 
> the samba.git repository is obviously working fine for me.
> Do you have any idea what could be the problem? I guess I'm missing 
> something... Should I also clone some other repo?

I guess you should not use http://gitweb ...:
please try

git clone git://git.samba.org/obnox/samba/samba-obnox.git


More soon.

Cheers - Michael
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 215 bytes
Desc: Digital signature
URL: <http://lists.samba.org/pipermail/samba-technical/attachments/20130926/e881f9ec/attachment.pgp>

More information about the samba-technical mailing list