Fwd: Error start bind9 samba4 BIND9_DLZ

Rowland Penny repenny241155 at gmail.com
Tue Sep 24 18:48:42 CEST 2013

On 24/09/13 17:00, Jacó Ramos wrote:
> I try to join the DC (Windows 2003 Server).
> I am using samba 4.0.9.
> Grato.
> Jacó Ramos
Hmm, I wonder if that is the problem, bind is trying to get the required 
data from the windows server and it isn't there.

I run a samba4 only setup and just set the main server up with 4.1.0rc3 
and bind 9.9.3 and then joined another DC to this, same samba4 version 
and again bind 9.9.3 absolutely no problem. I do remember though, that 
the last time I did this (and it was also the first time I did it), I 
tried to use the internal DNS server on the second DC and had allsorts 
of problems until I moved the second DC to bind9 as well.

So it just may be that you have found a bug, i.e. samba4 & bind cannot 
join a domain if the main DC is a windows server.

Have you tried turning off bind9 and then doing the join again, but this 
time without ' --dns-backend=BIND9_DLZ', if it does join ok, then the 
problem must be with your setup.

Just had another thought, the windows server is operating as a DNS 
server isn't it?


More information about the samba-technical mailing list