[Wireshark-dev] Wireshark PIDL generated dissectors

Matthieu Patou mat at samba.org
Sat Oct 26 00:54:17 MDT 2013

On 10/21/2013 04:27 PM, Joerg Mayer wrote:
> On Mon, Oct 21, 2013 at 03:48:35PM -0400, mmann78 at netscape.net wrote:
>> Checked most of the patches into r52744 (http://anonsvn.wireshark.org/viewvc?view=revision&revision=52744)
>> Didn't integrate
>> 0010-frsrpc-Regenerate-frsrpc-due-to-changes-in-the-pidl-.patch
>> 0016-Regenerate-the-dnserver.patch
>> due to compile errors on Windows from applying the patch in bug 9301 (https://bugs.wireshark.org/bugzilla/show_bug.cgi?id=9301).
>> See r52735 (http://anonsvn.wireshark.org/viewvc?view=revision&revision=52735) for how it was fixed.  Not sure if the PIDL compiler has to be changed for this one.
> I just tried to replace tools/pidl/ with the current samba rsync version.
> The result doesn't look too good:
> jmayer at egg:~/work/wireshark/svn/trunk/epan/dissectors/pidl> ../../../tools/pidl/pidl --ws-parser -- atsvc.idl
> defined(@array) is deprecated at /home/jmayer/work/wireshark/svn/trunk/tools/pidl/lib/Parse/Pidl/ODL.pm line 73.
>          (Maybe you should just omit the defined()?)
> defined(@array) is deprecated at ../../../tools/pidl/pidl line 608.
>          (Maybe you should just omit the defined()?)
> Compiling atsvc.idl
> /usr/include/stdc-predef.h:0: error: Syntax error near '3'
> Failed to parse atsvc.idl at ../../../tools/pidl/pidl line 608.
> jmayer at egg:~/work/wireshark/svn/trunk/epan/dissectors/pidl> perl -version
> This is perl 5, version 16, subversion 2 (v5.16.2) built for i586-linux-thread-multi
> [...]
> Any idea about what's going wrong here?
Hum honestly no ...
But on my laptop it's working pretty well:

mat:~/workspace/wireshark/epan/dissectors/pidl [(master)]$ rsync -a 
rsync.samba.org::ftp/pub/unpacked/samba_4_0_test/pidl .
Welcome to the samba.org anonymous rsync archives.

Contact tpot at samba.org if you have problems with this service.


mat:~/workspace/wireshark/epan/dissectors/pidl [(master)]$ ./pidl/pidl 
--ws-parser -- atsvc.idl
Compiling atsvc.idl
mat:~/workspace/wireshark/epan/dissectors/pidl [(master)]$ perl -version

This is perl 5, version 14, subversion 2 (v5.14.2) built for 
(with 80 registered patches, see perl -V for more detail)

Copyright 1987-2011, Larry Wall

Perl may be copied only under the terms of either the Artistic License 
or the
GNU General Public License, which may be found in the Perl 5 source kit.

Complete documentation for Perl, including FAQ lists, should be found on
this system using "man perl" or "perldoc perl".  If you have access to the
Internet, point your browser at http://www.perl.org/, the Perl Home Page.

> And when I try to do a "make install" for pidl and then run it:
> jmayer at egg:~/work/wireshark/svn/trunk/epan/dissectors/pidl> pidl --ws-parser -- atsvc.idl Can't locate Parse/Pidl.pm in @INC (@INC contains: /usr/bin/../share/perl5 /usr/bin/lib /usr/lib/perl5/site_perl/5.16.2/i586-linux-thread-multi /usr/lib/perl5/site_perl/5.16.2 /usr/lib/perl5/vendor_perl/5.16.2/i586-linux-thread-multi /usr/lib/perl5/vendor_perl/5.16.2 /usr/lib/perl5/5.16.2/i586-linux-thread-multi /usr/lib/perl5/5.16.2 /usr/lib/perl5/site_perl .) at /usr/bin/pidl line 410.
> BEGIN failed--compilation aborted at /usr/bin/pidl line 410.
> Which looks like the make install target doesn't work on opensuse 12.3.
Haven't tried the make install I just rsync in the same directory
> Ciao
>      Jörg


Matthieu Patou
Samba Team

More information about the samba-technical mailing list