[RFC PATCH v2 1/5] locks: consolidate checks for compatible filp->f_mode values in setlk handlers

Christoph Hellwig hch at infradead.org
Thu Nov 21 10:35:34 MST 2013

On Wed, Nov 20, 2013 at 11:45:02AM -0500, Jeff Layton wrote:
> Add a wrapper around assign_type that does this instead of duplicating
> this check in two places. This also fixes a minor wart in the code where
> we continue referring to the struct flock after converting it to struct
> file_lock.

I don't think posix_assign_type is a good name for this helper, but
as Bruce already pointed out more work is required in that area anyway.

More information about the samba-technical mailing list