Samba POSIX ACL behavior

Steve French smfrench at
Thu Nov 14 11:13:35 MST 2013

> I recently encountered the following strange behavior as mentioned in
> this post from several years ago:
> I'm currently running Ubuntu 12.04 LTS on desktop and server, so
> I took some time to try the latest packaged versions of Samba and
> the kernel to make sure that the issue had not yet been fixed.
> Client:  Ubuntu 12.04 LTS with Kernel 3.11.0-13-generic
> Server:  Ubuntu 12.04 LTS with Samba 3.6.20 and Kernel 3.5.0-43-generic
> I tried many other combinations and the behavior is the same.  It
> looks like setting default ACLs somehow interacts with the
> non-default ACLs and vice versa.

I tried this here to Samba 3.6 with slightly different results:
1) If I set both a default and non-default ACL that seems to work
2) but as you and Rob saw, if I setfacl a default ACL it removes the
non-default ACL
3) and if I setfacl a non-default ACL it removes the default ACL

So for case 2 and 3 the behavior is different than for a local file
system.  This may be a server bug.

For Samba 4 and Samba 4.2-pre (master) - I get an error not supported on
this infolevel 512 (Set POSIX ACL).



More information about the samba-technical mailing list