[PATCH] Rename variables used by loadparm
abartlet at samba.org
Tue Dec 24 00:21:19 MST 2013
On Tue, 2013-12-24 at 17:21 +1300, Garming Sam wrote:
> (resend from correct account)
> This set of changes renames a large number of variables used by loadparm
> in an effort to simplify and unify the naming scheme. This should be
> helpful for potential future work in auto-generating param_functions.c
> and param_table.c from the xml-documentation.
> We skipped domain_master and printername this time around due to the
> automated script causing issues. Andrew Bartlett and I have visually
> inspected every one of these patches.
> Please review and push. It's on top of metze's master4-schannel-ok
> branch to avoid conflicts with his pending work.
We spent the time this afternoon writing some global-replace scripts to
handle this safely, one change per commit. They worked very well, but
we skipped domain_master and printername for now because some of the
automatic renames were not as tidy as we would have liked. The rest
are, with only a couple of exceptions, all from the automated script and
so are all consistent.
The variable in the global or service structure is now always the name
of the lp_ and lpcfg_ function (we don't need two different identifiers
Andrew Bartlett http://samba.org/~abartlet/
Authentication Developer, Samba Team http://samba.org
Samba Developer, Catalyst IT http://catalyst.net.nz/services/samba
More information about the samba-technical