S4.0.4 Internal DNS problem: WERR_DNS_ERROR_DS_UNAVAILABLE after PDC being offline permanently.....

Gilberto Jémenez Pineda gjpineda21 at gmail.com
Wed Apr 24 12:14:10 MDT 2013

The problem is:
Two DC on my Active directory:
1st with Win2K8.R2 --- DC (DNS Master) --- server2k8.mydom.com
2nd with Samba 4.0.4 ---DC (Installed:
----- samba-dc.mydom.com

>>>>>Everything worked perfectly>>>>> 1000000 tanks for Samba Team.
Some days ago, the hard disk in Win2K8.R2 DC broke down, PDC offline
permanently..... I transferred all roles to samba-dc, Everything
worked perfectly... DNS query Ok...

Now, I can't manage the Samba Internal DNS, any action gave me an errors:
root at samba-dc:~# samba-tool dns zonelist samba-dc.mydom.com -U administrator
ERROR(runtime): uncaught exception - (9717, 'WERR_DNS_ERROR_DS_UNAVAILABLE')

root at samba-dc:~# samba_dnsupdate --verbose
Failed to find DNS entry SRV
samba-dc.mydom.com 389
couldn't get address for 'server2k8.mydom.com': not found

>>>>>>> I see strange:
root at samba-dc:~#  host -t SOA mydom.com
mydom.com has SOA record server2k8.mydom.com. hostmaster.mydom.com.
4316 900 600 86400 3600

root at samba-dc:~# host -t SRV _kerberos._tcp.mydom.com.
_kerberos._tcp.mydom.com has SRV record 0 100 88 server2k8.mydom.com.
_kerberos._tcp.mydom.com has SRV record 0 100 88 samba-dc.mydom.com.

>>>>>>>>>>>>>>>>>>>>>>Please, how I can completely remove the Win2k8 DC? How to Fix DNS record to point to the Samba DC? This could eliminate errors and make available DNS management?
samba-tool dns does not work, I made these using ldbedit? Who to?
Hope you can help me.
Thanks in advance, and congratulations for your excellent work.

More information about the samba-technical mailing list