"Clock skew too great" but clocks synchronized?

simo idra at samba.org
Sat Sep 29 13:44:23 MDT 2012

On Sat, 2012-09-29 at 16:06 +0200, Christian Huldt wrote:
> 2012-09-29 kl. 15:58 skrev simo:
> > On Sat, 2012-09-29 at 13:50 +0200, Christian Huldt wrote:
> >> A short time ago I stopped being able to login to a samba 3.6.3 member server on a domain a samba4 beta8 dc ,
> >> kinit on he member reported "Clock skew too great" but the time was on 4 seconds off, and even after synchronizing the clocks I still get the same message.
> >> date -u and date are the same on both machines.
> >> 
> >> I just don't understand it at all. Please, could some one think of anything?
> > 
> > Are you sure the time zone is the same ?
> > 
> Yes, I just verified that.
> It's been working perfectly for two weeks, and the other member servers connect/kinit just fine.

Have you tried kdestroy before doing kinit ?
Some versions of MIT save a 'clock skew' flag in the ccache and may try
to adjust the clock based on the previous skew.


Simo Sorce
Samba Team GPL Compliance Officer <simo at samba.org>
Principal Software Engineer at Red Hat, Inc. <simo at redhat.com>

More information about the samba-technical mailing list