gpfs vfs incorrectly returning offline status 'at random' in 3.6 and up

Barry Evans bevans at
Thu Sep 27 14:29:27 MDT 2012


I am having a strange issue with the vfs_gpfs module telling windows that certain files are offline, which then get displayed with an 'O' attribute and a big 'X' overlay in explorer for the file icon. If you come back into the directory the same thing will happen but it could be an entirely different set of files that get marked as offline. These files are indeed online and there is no presence of HSM within the setup.

mmlsattr returns only ARCHIVE for each file this occurs with

I have tried this GPFS 3.4.0-10, 3.4.0-15, 3.5.0-2 and 3.5.03, all with the same result. (OS is base RHEL 6.2 and RHEL 6.3). This has appeared in XP, 7 and Server 2003 and Server 2008.

Example from log level 10:

[2012/09/27 20:50:48.588160, 10] modules/vfs_gpfs.c:1224(vfs_gpfs_is_offline)
  xx/xx/xx/xx/xx/xx/xx/xx/xx.1015.exr is offline

x's replacing pathnames for security in example

I have also tried this with enterprise samba 3.5.18-44, this seems to work fine and the condition does not occur.

Any one seen anything like this?

Many Thanks,
Barry Evans

More information about the samba-technical mailing list