Backing up samba4

Marc Muehlfeld Marc.Muehlfeld at
Wed Sep 19 07:55:22 MDT 2012

Am 19.09.2012 15:27, schrieb steve:
> I just did it on a test LAN. I deleted /usr/local/samba and rsynced it back.
> samba fired up fine. xp and w7 clients could log in and GPO's were respected.
> What is the problem in doing this? It works with openSUSE 12.2. It fails with
> ubuntu lts.

I guess it worked, because during the rsync, nothing was changed in the 
tdb/ldb files, because it's a small test network. If you have a bigger 
network, where the databases often changes, it could happen that this appears 
during your rsync. Then you have a corrupt/inconsistent "backup".

I think for the tdb/ldb files tdbdump is a must.

In my backup script I run tdbbackup for all that files to generate the *.bak 
of them and then tar the whole to a save place (with ext. ACLs). So I can copy 
it back and have a hopefully save backup of the databases if neccessary.

On Rowlands initial question, how to to restore tdbbackup files:

I haven't tried it yet. But let me know if tdbrestore is the working way.


Marc Muehlfeld (IT-Leiter)
Zentrum fuer Humangenetik und Laboratoriumsmedizin
Dr. Klein, Dr. Rost und Kollegen
Lochhamer Str. 29 - D-82152 Martinsried
Telefon: +49(0)89/895578-0 - Fax: +49(0)89/895578-780

More information about the samba-technical mailing list