Samba4 beta8: samba daemon doesn' t start nmbd daemon !

Oooo1 oooo1 at
Fri Sep 7 14:55:37 MDT 2012

Hi anybody.

I use Samba4 beta8 as AD DC. But also I need fully working file server with
showing it at neighborhood.

In Samba4 beta6 I run samba as main daemon, then nmbd that server could be
showed at neighborhood.

But in beta8 doc is written: "When running an AD DC, you only need to run
'samba' (not nmbd/smbd/winbind), as the required services are co-coordinated
by this master binary. "

And at the same time there is "There is no NetBIOS browsing support (network
neighborhood) available for the AD domain controller." also.

If I run samba daemon only, it starts in itself, and also starts smbd daemon
(ps ajx |grep samba or smbd could show that) and there is access to the
server by NetBios protocols.

But samba daemon doesn' t start nmbd daemon at all - there is no such
process in the memory and the server is not showed at neighborhood.

But if I try to run nmbd separately (while samba daemon is in memory) , nmbd
is not started and I get an error:

  nmbd version 4.0.0beta8 started.

  Copyright Andrew Tridgell and the Samba Team 1992-2012

[2012/09/07 22:20:02,  0] ../source3/nmbd/nmbd.c:896(main)

  server role = 'active directory domain controller' not compatible with
running nmbd standalone.

  You should start 'samba' instead, and it will control starting the
internal nbt server


And I doesn' t still have the server being showed at neighborhood and could
not load nmbd manually separately.

I has nbt as server service in smb.conf also.


What should I do that Samba4 beta8 could be as AD DC and at the same time
could be showed at neighborhood ?

Or is it simply issue and samba damon has to load nmbd also ?

Or will it be done in coming Samba4 betas ?

More information about the samba-technical mailing list