/usr/local/samba/sbin/winbindd broken?

Rowland Penny repenny at f2s.com
Sat Sep 1 07:10:18 MDT 2012

On 30/08/12 11:14, Rowland Penny wrote:
> On 30/08/12 10:46, Kai Blin wrote:
>> On 2012-08-30 10:55, Rowland Penny wrote:
>> (now with samba-technical on CC again, sorry for the repost Rowland)
>> Hi Rowland,
>> I just wanted to make sure that you're not running the winbind service
>> included in the 'samba' binary, as that's very different and doesn't
>> support many of the idmapping options the 'winbindd' binary provides.
>>> Stop me if I am wrong, but as far as I am aware, winbind is supposed to
>>> pull the posix info from the server database. If this is so, then
>>> /usr/local/samba/sbin/winbindd is broken, as I only get the non-posix
>>> info i.e. it does not work like S3 winbind.
>> The interesting question would be finding out what is different. The
>> code in winbindd from the "master" branch (which is what people here
>> keep calling S4) should be pretty similar to the code from the 3.6
>> release branch.
>> Now, to get a clearer view of your setup, I take it that you're using
>> nss_winbind, right?
> If you mean, have I created the symlink from /lib/libnss_winbind.so.2 
> to /usr/local/samba/lib/libnss_winbind.so.2 and added winbind to 
> /etc/nsswitch.conf, then yes.
>> You said you were having issues joining the AD from the client. It's
>> probably worth starting to debug that.
> I was only having trouble joining when I tried out something Steve 
> suggested, joining is normally no trouble.
>> As far as I see,
>> rowland:*:1105:1103:rowland:/home/HOME/rowland:/bin/bash
>> means that winbind is in fact mapping the user, it's just falling back
>> to the default entry instead of using the AD information. This looks
>> like there's some issue in the client<->AD trusts.
>> On the s4 client, can you recheck if the 'net' binary you're calling is
>> the one you compiled? I've had two net binaries installed once and all
>> my machine keys ended up in the wrong database.
>> Cheers,
>> Kai
> which net
> /usr/local/samba/bin/net
> /usr/local/samba/bin/net -V
> Version 4.0.0beta8-GIT-e39cce4
> net -V
> Version 4.0.0beta8-GIT-e39cce4
> I have also checked every dir in my path, and it is only installed 
> once. I removed all traces of S3 before
> compiling S4.
> Thanks for the help.
> Rowland

OK, I did a git pull and compiled again, I am now running Version 

Still the same problem, but nothing in the logs so I upped the log level 
to 4 and got this in log.winbindd:

[2012/09/01 13:34:01.536460,  3] 
   [32427]: getpwent
[2012/09/01 13:34:01.544229,  3] 
   nss_init: no nss backends configured.  Defaulting to "template".
[2012/09/01 13:34:01.544474,  4] 
   nss_map_to_alias: Failed to find nss domain pointer for HOME

To me, it seems to be saying that the nss backend is not set, but I have 
the line 'winbind nss info = rfc2307' in /usr/local/samba/etc/smb.conf

Anybody have any suggestions how I can fix this?


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the samba-technical mailing list