Internal dns server changed between RC2 & 4.1.0pre1-GIT-2c3a808

Kai Blin kai at
Mon Oct 15 10:37:27 MDT 2012

On 2012-10-15 18:07, Rowland Penny wrote:

Hi Rowland,

> Hello, I set Samba 4 RC2 to update the internal nameserver via dhcp
> using a script, this works ok. I have compiled and installed
> 4.1.0pre1-GIT-2c3a808 and dhcp updating the nameserver no longer works!

I need more details here. How did the script work?

> Everything is the same, only the version of Samba4 has changed

Yes, we fixed

> If I run netstat -nlp | grep LISTEN | grep 53 on RC2 I get:
> tcp        0      0* LISTEN      810/samba
> tcp6       0      0 fe80::e2cb:4eff:fe06:53 :::* LISTEN      810/samba
> But on 4.1.0pre1-GIT-2c3a808 I get:
> tcp        0      0    * LISTEN     
> 22350/samba
> tcp6       0      0 :::53                   :::* LISTEN      22350/samba
> If I run the script manually: /usr/local/sbin/ add
> LinPad
> I get:
> root at adserver:~# dns_tkey_negotiategss: TKEY is unacceptable
> specified zone '' does not exist (NXDOMAIN)
> dhcpd: DDNS: adding records for <LinPad.home.lan> FAILED:
> status 10
> Why is the TKEY suddenly unacceptable? and why is it saying the reverse
> zone does not exist when it does, as I created it and samba-tool lists it?.

What happens if you query records from outside of
that update? Are you using the correct Kerberos keys?

A network capture might help.


Kai Blin
Worldforge developer
Wine developer
Samba team member

More information about the samba-technical mailing list