Rowland Penny repenny at f2s.com
Thu Nov 22 12:45:47 MST 2012

On 22/11/12 14:53, Jelmer Vernooij wrote:
> On Wed, Nov 21, 2012 at 12:04:34PM +0000, Rowland Penny wrote:
>>   we seem to have an interesting problem here, Andrew Bartlett has
>> created a Samba bug report: Bug 9415 - SWAT *.msg files not
>> installed with waf
>> This by itself is not a problem, but it is also listed as a blocker
>> on Bug 8622 - Samba 4.0 can't be released
>> So what is the problem? the problem is that Samba 4 cannot be
>> released until bug 9415 is sorted out, but why bother because Swat
>> itself is so broken and out of date it cannot be installed. It relys
>> on pylons, but pylons seem to have been replaced by pyramids.
>> So Andrew you want a cure for bug 9415, easy, just remove Swat until
>> it is sorted out and works.
>> Before anybody starts shouting, I have tried to follow the
>> instructions at https://wiki.samba.org/index.php/SWAT2
>> None of the instructions there seem to work on Ubuntu 12.04 server
>> and the page was last modified on 7 September 2011. I have also
>> tried searching the web for newer instructions but cannot find any
>> at this time.
>> If anybody knows how to get Swat working, could they please post a
>> howto somewhere.
> I've updated the HOWTO at https://wiki.samba.org/index.php/SWAT2.
> You'll also need the patches I recently posted to the mailing list for
> the web service.
> Cheers,
> Jelmer
Hi Jelmer,
I have applied your patches and compiled samba 4 again, carried out the 
instructions on the swat2 howto page and got swat2 running (I think) ;-)

netstat -a | grep LISTEN | grep -v unix
tcp        0      0 *:swat                  *:* LISTEN

lsof -i :901
samba   31644 root   22u  IPv4 433197      0t0  TCP *:swat (LISTEN)
samba   31644 root   23u  IPv6 433198      0t0  TCP *:swat (LISTEN)

But when I try to connect to swat (via the servers ipaddress) from 
another computer, I get this in /usr/local/samba/var/log.samba

[2012/11/22 19:34:40,  0] 
   error while running WSGI code

I also now have an empty /usr/local/samba/var/log.swat

Any idea what is wrong?


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the samba-technical mailing list