Rowland Penny repenny at f2s.com
Wed Nov 21 14:53:02 MST 2012

On 21/11/12 20:59, Jelmer Vernooij wrote:
> On Wed, Nov 21, 2012 at 01:02:52PM +0000, Rowland Penny wrote:
>> On 21/11/12 12:47, Andrew Bartlett wrote:
>>> On Wed, 2012-11-21 at 12:04 +0000, Rowland Penny wrote:
>>>> Hello,
>>>>    we seem to have an interesting problem here, Andrew Bartlett has
>>>> created a Samba bug report: Bug 9415 - SWAT *.msg files not installed
>>>> with waf
>>>> This by itself is not a problem, but it is also listed as a blocker on
>>>> Bug 8622 - Samba 4.0 can't be released
>>>> So what is the problem? the problem is that Samba 4 cannot be released
>>>> until bug 9415 is sorted out, but why bother because Swat itself is so
>>>> broken and out of date it cannot be installed. It relys on pylons, but
>>>> pylons seem to have been replaced by pyramids.
>>> You are confusing SWAT with SWAT2.  The bug represents a simple patch to
>>> our wscript files that won't take long to sort out, but which I don't
>>> quite have time for right now.  Blocker bugs like this go in and out of
>>> that tracker each day, it isn't a great drama.
>>> SWAT is pure C.  The various SWAT2 efforts don't seem to have come to a
>>> productive result, which is sad, but that is up to those maintaining
>>> those efforts, which are outside Samba at this point.
>>> Andrew Bartlett
>> Ok and thanks for clarifying that Andrew, but as that is the case,
>> it raises a couple of further questions:
>> does swat work with samba4 and if so how do you use it?
>> I tried running the swat binary and going to
>> but this does not work, I also tried https, this did not work
>> either.
> The old SWAT is an inetd application. See the manpage for details on
> how to install it:
> http://www.samba.org/samba/docs/man/manpages-3/swat.8.html
> Cheers,
> Jelmer
Thanks Jelmer, I had a look at the page you suggested, it turned out 
that you need to use xinetd on Ubuntu 12.04 but I got it working. Having 
tried it out, I cannot recommended it, it knows nothing about the samba 
daemon and displays both the conf files as if there was only one.
My personal opinion is as before, it is time to remove the old swat from 
samba4 and then get the new one to work, I finally got the new one to 
install, it just will not run.


This message has been scanned for viruses and
dangerous content by MailScanner, and is
believed to be clean.

More information about the samba-technical mailing list