Samba 4 RC5 make error

BlackPenguin ADMIN admin at
Wed Nov 14 06:00:25 MST 2012

My cups version is pretty up to date I guess.


If I look in wscript, there is no cups showing up. Cups is started and 
running. This worked perfectly in samba 4 RC3... Not sure what changed 
since then. I am running kernel-3.6.6-1.fc17.x86_64

On 11/13/2012 11:00 PM, Andrew Bartlett wrote:
> On Tue, 2012-11-13 at 18:27 -0700, BlackPenguin ADMIN wrote:
>> Hi,
>> I am getting this error when running the make on samba 4 RC5. I got the
>> same error on make on samba 4 RC4:
>> ERROR: Target 'cups' in directory /root/samba-4.0.0rc5/source3
>> re-defined as EMPTY - was SYSLIB
>> Please let me know what's the cause and the fix... Thanks!
> My guess is that you have cups, but a version that is too old or
> otherwise fails the code in source3/wscript.  What version of the cups
> do you have, and do you have cups/cups.h and cups/language.h as a system
> header?
> Thanks,
> Andrew Bartlett

*BlackPenguin ADMIN*

*e-mail:* 	admin at <mailto:admin at>

	*Powered by Fedora Linux - Free as in freedom*

More information about the samba-technical mailing list