Samba compile failure on Sun5.10

Mihai-Radu, Orza orzamihai at
Wed May 16 07:06:48 MDT 2012


Below is the grep output. I'm not sure if this is of any interest, but while running configureI got the following warning: "Unknown host_os 'solaris-sparc64', please report this to samba-technical at".

-bash-3.00$ grep "rep_" lib/replace/snprintf.c
 int rep_vsnprintf (char *str, size_t count, const char *fmt, va_list args)
 int rep_snprintf(char *str,size_t count,const char *fmt,...)
 int rep_printf(const char *fmt, ...)
 int rep_fprintf(FILE *stream, const char *fmt, ...)
 int rep_vasprintf(char **ptr, const char *format, va_list ap)
 int rep_asprintf(char **ptr, const char *format, ...)


 From: Jelmer Vernooij <jelmer at>
To: "Mihai-Radu, Orza" <orzamihai at> 
Cc: "samba-technical at" <samba-technical at> 
Sent: Wednesday, May 16, 2012 2:20 PM
Subject: Re: Samba compile failure on Sun5.10

On Tue, May 15, 2012 at 03:56:39AM -0700, Mihai-Radu, Orza wrote:
> I pulled the latest version of samba4 from git, but I still get the same asn_compile1 error when running make.
> How can I get the fix that you mentioned?
Can you grep for "rep_" in lib/replace/snprintf.c to verify you have
the fix in your copy of Samba?



> Am 11/05/12 16:39, schrieb Mihai-Radu, Orza:
> > I apologize if this was already posted or explained.
> > I am trying to compile samba4 alpha19 on a Sun5.10 sparc machine. I ran the confgure script (./configure --prefix=/tmp/dist) and that worked fine. But when I ran make, I got the following error:
> >
> >
> > [ 107/3850] Linking default/source4/heimdal_build/asn1_compile
> > Undefined                       first referenced
> >   symbol                             in file
> > rep_vasprintf                       default/source4/heimdal/lib/roken/strpool_5.o
> > rep_snprintf                        default/source4/heimdal/lib/roken/getarg_5.o
> > rep_asprintf                        default/source4/heimdal/lib/asn1/gen_134.o
> > ld: fatal: Symbol referencing errors. No output written to /tmp/samba-4.0.0alpha19/bin/default/source4/heimdal_build/asn1_compile
> > collect2: ld returned 1 exit status
> > Waf: Leaving directory `/tmp/samba-4.0.0alpha19/bin'
> > Build failed:  -> task failed (err #1):
> >          {task: cc_link base64_5.o,ct_5.o,hex_5.o,bswap_5.o,dumpdata_5.o,emalloc_5.o,ecalloc_5.o,getarg_5.o,get_window_size_5.o,getdtablesize_5.o,h_errno_5.o,issuid_5.o,net_read_5.o,net_write_5.o,parse_time_5.o,parse_units_5.o,vis_5.o,strlwr_5.o,strsep_copy_5.o,strsep_5.o,strupr_5.o,strpool_5.o,estrdup_5.o,erealloc_5.o,simple_exec_5.o,strcollect_5.o,rtbl_5.o,rand_5.o,cloexec_5.o,xfree_5.o,replace_5.o,print_version_132.o,version_132.o,main_134.o,gen_134.o,gen_copy_134.o,gen_decode_134.o,gen_encode_134.o,gen_free_134.o,gen_glue_134.o,gen_length_134.o,gen_seq_134.o,gen_template_134.o,hash_134.o,symbol_134.o,asn1parse_134.o,lex_134.o,strptime_1.o,replace_1.o,timegm_1.o -> asn1_compile}
> > make: *** [all] Error 1
> I've pushed a fix for this to autobuild.
> Cheers,
> Jelmer

More information about the samba-technical mailing list