remove chain_reply() ?

Andrew Bartlett abartlet at
Thu Mar 1 16:44:02 MST 2012

On Thu, 2012-03-01 at 23:38 +0100, Volker Lendecke wrote:
> On Wed, Feb 29, 2012 at 12:41:13AM +0100, Volker Lendecke wrote:
> > > > >;a=shortlog;h=refs/heads/chain_reply
> > Now it survives the new chain3 test as well, which makes the
> > first open&x request having to break an oplock.
> This is a call for help with the autobuild system. With the
> above patchset I repeatably get
> [282/458 in 16m39s] samba3.smb2.scan (s3dc)
> [283/458 in 16m44s] samba3.smb2.scanfind (s3dc)
> [284/458 in 16m44s] samba3.smb2.rename (s3dc)
> [285/458 in 16m44s] samba3.rpc.authcontext (s3dc)
> [286/458 in 16m44s] samba3.rpc.samba3.bind (s3dc)
> [287/458 in 16m44s] samba3.rpc.samba3.srvsvc (s3dc)
> Using seed 1330636008
> Testing NetShareEnum level 0
> Testing NetShareEnum level 1
> Testing NetShareEnum level 2
> Testing NetShareEnum level 501
> Testing NetShareEnum level 502
> WARNING!: NetShareEnum level 502 failed - NT_STATUS_IO_TIMEOUT
> Testing NetShareEnum level 1004
> ERROR: Testsuite[samba3.rpc.samba3.srvsvc (s3dc)]
> REASON: /memdisk/vlendec/manual/b835/samba3/source3/bin/smbtorture4
> --configfile=$SMB_CONF_PATH
> --maximum-runtime=$SELFTEST_MAXTIME --target=samba3
> --basedir=$SELFTEST_TMPDIR
> --option="torture:winbindd_netbios_name=$SERVER"
> --option="torture:winbindd_netbios_domain=$DOMAIN"
> --option=torture:sharedelay=100000
> --option=torture:progress=no --format=subunit $LISTOPT
> //$SERVER_IP/tmp -U$USERNAME%$PASSWORD rpc.samba3.srvsvc
> //$LOADLIST 2>&1 |
> ///memdisk/vlendec/manual/b835/samba3/selftest/filter-subunit
> //$LISTOPT --fail-on-empty
> //--prefix="samba3.rpc.samba3.srvsvc ." died with signal 9,
> //without coredump
> (cut&paste killed formatting).
> I have no clue how to debug this in the autobuild system on
> sn-devel. Cranking up the debug level of smbd to 10 makes it
> fail much earlier, also with the unmodified master.

Just a heads-up.  I know you will find this infuriating, but the make
test failure with debug level 10 might be a red herring.  Any output
line, including from a DEBUG() starting with 'error' is counted by
subunit as a failure, and so will cause an autobuild to fail.  

We need to remove the last of these from our debug messages (I already
removed some, after similar head-banging), but if you instead choose
debug level 9, does it still fail early with an unmodified master, and
also with your patch?

> Jeremy says we need the patchset, so just ditching it
> because I can't make it get through autobuild might not be
> the right solution. But I tried for almost 2 days now to get
> this through and have to give up.
> As you might have guessed, running "make test" without the
> autobuild environment as well as directly running the test
> against a local smbd run just fine.
> Any ideas?

The strangest thing about this failure is that it happens on the samba3
test first.  It should have failed on the top level waf build first, as
that build completes 

The things I usually try (chasing down a similar difficult issue with
our ktest environment right now) are local autobuilds
(./script/ --testbase=/data/autobuild) on my own
workstation, and manual autobuilds on sn-devel

You said that make test succeeds.  Is this on sn-devel or locally?

In autobuild, make test is run as:


Does running that change if make test alone fails?

I hope some of these clues assist you and others in dealing with what
can be a quite infuriating situation. 

Andrew Bartlett

Andrew Bartlett                      
Authentication Developer, Samba Team 

More information about the samba-technical mailing list