SOLVED: Samba4 getent Broken???

Scott Jordahl scott at
Sat Jun 30 14:30:08 MDT 2012

On 06/30/2012 12:46 PM, Scott Jordahl wrote:
> On 06/29/2012 09:52 PM, Matthieu Patou wrote:
> >On 06/28/2012 02:14 PM, Scott Jordahl wrote:
> >> I'm having issues trying to get getent to show domain users/groups.
> >> This, consequently, means I cannot see actual user name/groups when
> >> doing an "ls -l" on the Samba host (just the assigned idmap number).
> >>
> >> Here is my setup:
> >> Host: Ubuntu x64 10.04 LTS
> >> Samba compiled from: samba-4.0.0beta2.tar.gz
> >>
> >> Here is what I have done:
> >> o Appended "winbind" to the passwd and group entries in nsswitch.conf
> >> o Copied to /lib and created the symlink
> >> /lib/ ->  /lib/
> >> o Misc: apparmor has been removed
> >> o ldconfig -v shows " ->"
> >>
> >> When I execute wbinfo with any of the options, it works perfectly and
> >> outputs what is expected.
> >> When I execute getent, I only get a dump of the local users/groups. I
> >> also tried: "getent passwd "DOM\user", and it returns an empty string.
> >> I'm not getting any error messages and nothing is showing up in any of
> >> the logs. Am I suppose to include an option with "configure" to enable
> >> this function before building Samba?
> >>
> >Can you strace the getent and see if it's talking to the same unix
> >socket as wbinfo does ?
> >
> >Thanks.
> >Matthieu.
> Well, I'm not sure what's going on, but I built and installed beta2 on 
> another Ubuntu x64 10.04 LTS server, and getent works fine. I need to 
> go back to my first server and troubleshoot why nss is not resolving 
> correctly. I'll let you know what I find out.
> Thanks,
> -- Scott

Wow. Last year I built a test version of an alpha Samba4 and configured 
it to use an alternate base directory structure (/test/samba). I since 
removed that directory. The installer for the alpha build (I assume) 
created the file: /etc/ with a pointer to 
/test/samba/lib. This file did not get updated when installing beta2. 
getent was trying to find winbindd using the old, removed library path. 
Once I updated /etc/ to look in 
/usr/local/samba/lib and ran ldconfig, getent was happy.

Thanks Matthieu for the strace suggestion.

-- Scott

More information about the samba-technical mailing list