Need urgent help with samba4 DC re-join

Andrew Bartlett abartlet at
Wed Jun 27 04:21:57 MDT 2012

On Wed, 2012-06-27 at 08:21 +0200, Andreas Oster wrote:
> Hello all,
> today I have tried to fix replication of ForestDnsZones and
> DomainDnsZones. I pulled the current sources from GIT and recompiled
> samba4. After installation I demoted the second DC, which completed
> without any errors. Afterwards I have tried to re-join the server but
> this is constantly failing. I have attached the d3 output of the join
> attempt.
> In the PDC log.samba the following error comes up when joining of the
> second DC failes:
> [2012/06/27 08:13:30,  0] ../source4/dsdb/common/util.c:2689(dsdb_savereps)
>   Failed to store repsTo - objectclass_attrs: attribute 'dc' on entry
> 'DC=DomainDnsZones,DC=novanetwork,DC=loc' does not exist in the
> specified objectclasses!
> [2012/06/27 08:13:30,  0]
> ../source4/rpc_server/drsuapi/updaterefs.c:154(drsuapi_UpdateRefs)
>   Failed to delete repsTo for d54eb180-fd57-4629-8f8f-bb48373a8daa:
> Stupid as I am, I did this on the productive system :-(

Can you show us the full ldif for that DN on your PDC?

ldbsearch -H sam.ldb -s base -b DC=DomainDnsZones,DC=novanetwork,DC=loc
* objectClass repsFrom repsTo


Andrew Bartlett

Andrew Bartlett                      
Authentication Developer, Samba Team 

More information about the samba-technical mailing list