interactions between samba4 and samba3

Daniele Dario d.dario76 at
Mon Jun 25 09:18:38 MDT 2012

Hi list,
today I updated my two samba4 DCs to latest git tree.

Before to update secodary DC I demoted it to test DNS zones replication
after a re-join and I was very happy to see that after join, zones
automatically started to replicate and with samba_upgradedns I was able
to get private/dns stuff and than bind9 with DLZ backend worked fine.

I had a problem with the creation of the CNAME record of the re-joined
DC in the _msdcs zone (I removed the old one and add the new one with
samba-tool) but after that, all went fine.

After that I rebooted the two file servers with samba 3.4.7 but they
came up with this problem:
[2012/06/25 17:03:17,  1, pid=1140]
  Could not receive trustdoms
[2012/06/25 17:03:17,  1, pid=1140] libads/ldap.c:427(ads_find_dc)
  ads_find_dc: failed to find a valid DC on our site
(Default-First-Site-Name), trying to find another DC

Now, domain users can't map network shares.
Also smbclient (from file servers so smbclient 3) is not able to list
shares: I tried using -U root, -U administrator, -U DNSDOMAIN
+administrator, -U DNSDOMAIN\\administrator.

Anyone has had these issues or can tell me how fix the problem?

I'll test s3fs on samba4 before to migrate from 3.4.7 our network shares
but one of the 3.4.7 servers is used to allow logins from the internet
to our LAN so for now I need to keep it a 3.

Thanks in advance for your kind help,

More information about the samba-technical mailing list