How to get DNS replication working properly?

Mike Howard mike at
Sun Jun 24 16:11:07 MDT 2012

On 24/06/2012 15:11, Andrew Bartlett wrote:
> On Sun, 2012-06-24 at 10:33 +0100, Mike Howard wrote:
>> On 24/06/2012 08:35, Andrew Bartlett wrote:
>>> On Fri, 2012-06-22 at 17:32 +0200, Morten Kramer wrote:
>>>> Hi all,
>>>> I've been trying to get DNS replication to work for a few days now.
>>>> What I've done:
>>>> - Compile Samba (Beta1/Beta2/recent git pull) under Centos 6.2 x64
>>>> Any help will be greatly appreciated!
>>> Could you both please try
>>> git:// fix-dns-replication
>>> If you start with that, for a new join, it should do the replication of
>>> the DNS partitions.  Otherwise, follow the steps you took.
>>> Please let me know if this works, so I can get this in to master to
>>> assist others.
>>> Andrew Bartlett
>> I tried the two patches you posted the other day and using the internal
>> dns server got replication to work.
>> There was a minor issue of the secondary dc's details were not added to
>> the primary's dns at all. Easily added manually though. The SOA doesn't
>> include the secondary ns info
> Was this with a Samba4 joining Samba4, or Samba4 joining Windows?
> I've been continuing with testing, and in make test, the Samba4 ->
> Samba4 case fails quite badly (does not even create the separate
> partitions, puts some values in the main partition).
> I'll dig into this some more, but having a test case in make test makes
> this easier (not easy, but easier).
> Andrew Bartlett
I've just ran through this again, samba4 joining samba4, this time with 
--dns-backend=BIND9_DLZ and this also worked.
The only requirement was the fixing up of the file permissions on the 

Any question is easy if you know the answer!

More information about the samba-technical mailing list