updating samba4alpha15 to beta1

Andrew Bartlett abartlet at samba.org
Tue Jun 19 20:03:26 MDT 2012

On Sun, 2012-06-17 at 18:31 +0200, Christian Huldt wrote:
> 16 jun 2012 kl. 19.10 skrev Christian Huldt:
> > 
> > After first upgrading login2 without any problems (well, not more than before upgrading) I now get (after upgrading LOGIN1):
> > 
> > # /usr/local/samba/bin/samba-tool drs showrepl
> > ERROR(<class 'samba.drs_utils.drsException'>): DRS connection to login2.arkitekt.msg83 failed - drsException: DRS connection to login2.arkitekt.msg83 failed: (-1073741772, 'NT_STATUS_OBJECT_NAME_NOT_FOUND')
> >  File "/usr/local/samba/lib/python2.6/site-packages/samba/netcmd/drs.py", line 39, in 
> >    (ctx.drsuapi, ctx.drsuapi_handle, ctx.bind_supported_extensions) = drs_utils.drsuapi_connect(ctx.server, ctx.lp, ctx.creds)
> >  File "/usr/local/samba/lib/python2.6/site-packages/samba/drs_utils.py", line 54, in drsuapi_connect
> >    raise drsException("DRS connection to %s failed: %s" % (server, e))
> > 
> (Answering my own post)
> OK, so I tried to join my BDC to the domain again, and that didn't go:
> Setting account password for LOGIN2$
> Enabling account
> Calling bare provision
> No IPv6 address will be assigned
> get_nt_acl_no_snum: fset_nt_acl returned zero.
> Join failed - cleaning up
> checking sAMAccountName
> Deleted CN=LOGIN2,OU=Domain Controllers,DC=arkitekt,DC=msg83
> Deleted CN=NTDS Settings,CN=LOGIN2,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=arkitekt,DC=msg83
> Deleted CN=LOGIN2,CN=Servers,CN=Default-First-Site-Name,CN=Sites,CN=Configuration,DC=arkitekt,DC=msg83
> ERROR(<class 'samba.provision.ProvisioningError'>): uncaught exception - ProvisioningError: Your filesystem or build does not support posix ACLs, s3fs is unworkable in this mode
> funny thing is that I had user_xattr and acl enabled on the bdc (login2) but not on the pdc (login1), but got tha same error after enabling xattr and acl on the pdc.
> What should I do to get it going?

Do you have the acl development libraries installed?  

This is a new requirement, due to the new default file server.  You can
use the old default (ntvfs) by specifying --use-ntvfs, but we are trying
to move everyone to the s3fs file server, to avoid having both forever. 

Andrew Bartlett

Andrew Bartlett                                http://samba.org/~abartlet/
Authentication Developer, Samba Team           http://samba.org

More information about the samba-technical mailing list