Beta1 S3FS "The parameter is incorrect" on Win7

brendan powers brendan0powers at
Tue Jun 5 13:48:02 MDT 2012

I have some more information about this issue. To ensure that I was
reproducing a real issue, and not just an issue with my setup, I
decided to create a test from scratch. Here are the steps I used to
reproduce the issue.

1) Install Ubuntu 10.04
2) Check out samba4 Beta1
3) Configure with: ./configure.developer --enable-fhs
--prefix=/usr/local/ --with-syslog --with-logfilebase=/var/log/samba
--enable-cups --with-pam --with-acl-support
4) Provision with: provision --realm=testdom.lan --domain=TESTDOM
--adminpass=AdminPw123 --server-role=dc
5) Configure bind 9.8 do use the DLZ plugin and dynamic updates.

After that was all set up, I tested a XP and Win7 computer, and got
the same results as before. After that I tried joining both machines
to the domain. Once the machines were joined to the domain, everything
worked as expected. I was able to browse the shares as normal, and
edit permissions. So, this issue seems to only affect machines not
joined to the domain, or domains with incorrect DNS configurations.
Would it be appropriate to file a bug report for this issue?

Also, I noticed that the files in sysvol are not marked to inherit
permissions by default. I believe this is correct for the sysvol
folder itself, but not for any of it's sub-folders.

On Tue, Jun 5, 2012 at 1:22 PM, brendan powers <brendan0powers at> wrote:
> I've been having some issues testing the new S3FS features in the
> latest alpha and beta releases. When I browse to a share from a
> windows 7, or windows server 2008 machine, I get the error "The
> parameter is incorrect". If I access the share from a windows XP
> computer, I can browse the share, but I don't see the permissions tab.
> At one point, I could see the permissions tab, but when I tried to add
> a new user to the list, I got the above error. This leads me to think
> that the error is caused by some sort of ACL issue. I have POSIX ACLs,
> and xattibutes enabled. I tried starting samba with -i -M single -d9,
> but didn't see anything interesting when I accessed the share.
> However, I think that I'm just not getting debug output from the smb
> process. Is there something I need to do to get debug logs?
> I have an unrelated issue with print shares. I am able to get CUPS
> printer listed, however, when I try to connect to them, I get the
> error "Windows cannot connect to the printer." The error number is
> 0x0000002e. I'm not really sure printers are supposed to work, but I
> thought I'd try.

More information about the samba-technical mailing list