Beta1 S3FS "The parameter is incorrect" on Win7

brendan powers brendan0powers at
Tue Jun 5 11:22:22 MDT 2012

I've been having some issues testing the new S3FS features in the
latest alpha and beta releases. When I browse to a share from a
windows 7, or windows server 2008 machine, I get the error "The
parameter is incorrect". If I access the share from a windows XP
computer, I can browse the share, but I don't see the permissions tab.
At one point, I could see the permissions tab, but when I tried to add
a new user to the list, I got the above error. This leads me to think
that the error is caused by some sort of ACL issue. I have POSIX ACLs,
and xattibutes enabled. I tried starting samba with -i -M single -d9,
but didn't see anything interesting when I accessed the share.
However, I think that I'm just not getting debug output from the smb
process. Is there something I need to do to get debug logs?

I have an unrelated issue with print shares. I am able to get CUPS
printer listed, however, when I try to connect to them, I get the
error "Windows cannot connect to the printer." The error number is
0x0000002e. I'm not really sure printers are supposed to work, but I
thought I'd try.

More information about the samba-technical mailing list