Please help with samba 3.6 build

Ira Cooper samba at
Mon Jan 30 19:54:45 MST 2012

I personally use configure with 3.6.3 on OpenSolaris/NexentaCore.


On Mon, Jan 30, 2012 at 9:36 PM, Jiri Sasek - Solaris Prague <
jiri.sasek at> wrote:

> I am trying to update my build Makefile to samba 3.6.3 from the original
> samba 3.5.12 (both is build of source3)
> I run into the issue with build of "everything" target. It aims to build
> smbtorture4. This target fails because of it is not configured. It looks
> the problem is in the new build system called waf. I tried to look into the
>**php/Waf<>but text here looks to be outdated. All of the commands here are failing.
> Which only looks to work is:
>  cd <...>/source4/torture
>  ../../buildtools/bin/waf configure <parameters>
> ...but it looks the waf configure does not store its configure. When I try
> to build the "everything" target again it is also not configured and fails.
> Can anyone help me with waf?
> Thank youu in advance,
> Jiri
> My samba-3.5.12 build Makefile is in:
> components/samba/samba/<>

More information about the samba-technical mailing list