[Samba] Samba 4 will not start after new checkout [URGENT]

Michael Wood esiotrot at gmail.com
Thu Jan 19 23:51:30 MST 2012

On 19 January 2012 21:50, Charles Tryon <charles.tryon at gmail.com> wrote:
> I just tried again this morning, and other than needing to clean up some of
> the mess I made thrashing around the past couple of days, it appears to be
> fixed.
> **THANKS!!**

I suppose you should thank metze for that :)

> One oddity is that, to recover my database, I copied back one of the
> provisioning database backups that the upgrade provision step creates.  I
> then re-ran the "upgradeprovision" step.  This recovered the Samba database
> without any trouble, but then I couldn't restart the DLZ named process.
>  After doing some digging, I discovered that the
> .../samba/private/named.conf file was still pointing to the .so file in the
> "modules" directory rather than the new location in the "lib" directory.
>  I'm guessing that this is at the root of the recent script problem -- the
> libraries were moved to the "lib" dir, but something was still looking in
> the old location.  My question is, if you are just using upgradeprovision to
> roll your database from one update to the next, what should have changed the
> reference in the named.conf file?

Perhaps upgradeprovision should just print a warning at the end to
check that the path to dlz_bind.so is correct.

> On Thu, Jan 19, 2012 at 3:23 AM, Michael Wood <esiotrot at gmail.com> wrote:
>> On 19 January 2012 10:05, steve <steve at steve-ss.com> wrote:
>> > Hi everyone
>> >
>> > I've marked the thread as URGENT. Another post has reported similar
>> > during
>> > provisioning.
>> > Could someone on samba-technical send a copy there too?
>> It's been mentioned on samba-technical and I believe a fix was
>> committed yesterday/last night, but I haven't tried compiling Samba4
>> in the last week or so.
>> If you're still stuck, just roll back to a version from a few days
>> ago.  If you want some specify fix, cherry-pick it.
>> Also, you might want to subscribe to samba-technical if you're using
>> Samba4, since the HOWTO still says to report problems there (while
>> Samba4 is still in alpha).

Michael Wood <esiotrot at gmail.com>

More information about the samba-technical mailing list