Samba 4 and dhcp

Andrew Bartlett abartlet at
Wed Dec 26 03:17:00 MST 2012

On Wed, 2012-12-26 at 10:06 +0000, Rowland Penny wrote:
> On 26/12/12 09:37, Andrew Bartlett wrote:
> > On Thu, 2012-12-20 at 15:53 +0000, Rowland Penny wrote:
> >> Hi, I am having problems with the Samba 4 internal DNS server & DHCP,
> >> basically it has stopped working. It was working ok on RC5 and when I
> >> upgraded to the release version it stopped working. By checking the logs
> >> and running my script by hand, I get the following error:
> >> TSIG error with server: tsig verify failure
> >> I get the same error if I run nsupdate directly.
> >>
> >> Is this due to the same reason that requires the adding of
> >> 'acl:search=false' to /usr/local/samba/etc/smb.conf? If so, then adding it
> >> does not work for me, I have added it and restarted samba4 several times to
> >> no effect, I have also upgraded to version 4.1.0pre1-GIT-d846199 and it
> >> still does not work.
> > Rowland,
> >
> > If you can find the revision that it breaks on (with git bisect) this
> > would be very, very helpful.
> >
> > We are aware that there are issues with TSIG (a number of vague
> > reports), but we have not pinned anything down yet.
> >
> > Andrew Bartlett
> >
> Hi Andrew, whilst I am quite prepared to start rolling things back, what 
> the heck is 'git bisect' and how do I do it?
> Rowland

Grab the v4-0-test branch from git, and apply this tutorial to it:

With building Samba, it won't be 3 mins, but it will save you (and us) a
lot of time compared with manually guessing. 

I realise this may be a lot of work, and we can probably also debug it
directly, but this is something you can do on your own, if you have the
time, energy and resources. 

Andrew Bartlett

Andrew Bartlett                      
Authentication Developer, Samba Team 

More information about the samba-technical mailing list