Samba 4 and dhcp

Andrew Bartlett abartlet at
Wed Dec 26 02:37:45 MST 2012

On Thu, 2012-12-20 at 15:53 +0000, Rowland Penny wrote:
> Hi, I am having problems with the Samba 4 internal DNS server & DHCP,
> basically it has stopped working. It was working ok on RC5 and when I
> upgraded to the release version it stopped working. By checking the logs
> and running my script by hand, I get the following error:
> TSIG error with server: tsig verify failure
> I get the same error if I run nsupdate directly.
> Is this due to the same reason that requires the adding of
> 'acl:search=false' to /usr/local/samba/etc/smb.conf? If so, then adding it
> does not work for me, I have added it and restarted samba4 several times to
> no effect, I have also upgraded to version 4.1.0pre1-GIT-d846199 and it
> still does not work.


If you can find the revision that it breaks on (with git bisect) this
would be very, very helpful. 

We are aware that there are issues with TSIG (a number of vague
reports), but we have not pinned anything down yet.

Andrew Bartlett

Andrew Bartlett                      
Authentication Developer, Samba Team 

More information about the samba-technical mailing list