Problem with SYSVOL share

Andreas Oster aoster at
Wed Apr 25 02:45:23 MDT 2012

Am 25.04.2012 10:27, schrieb Matthieu Patou:
> On 04/25/2012 01:20 AM, Andreas Oster wrote:
>> Am 25.04.2012 09:52, schrieb Matthieu Patou:
>>> On 04/24/2012 11:41 PM, Andreas Oster wrote:
>>>> Hello all,
>>>> with current samba release from GIT (4.0.0alpha20-GIT-594e316) I face
>>>> a problem with the SYSVOL and NETLOGON share. When trying to access
>>>> these shares via \\domainname\sysvol or \\domainname\netlogon from a
>>>> Windows machine I'll get a access denied when I do the same with the
>>>> name of the domain controller (\\dcname\sysvol, \\dcname\netlogon) it
>>>> works without any problems. When I just enter \\domainname Explorer
>>>> opens and I can see the SYSVOL and NETLOGON share but are also
>>>> unable to
>>>> access the shares.
>>> Can you provide more context:
>>> * Are you using s3fs ?
>>> * Can you provide us a trace
>>> * Which clients ?
>>> Matthieu
>> Hello Matthieu,
>> attached you'll find two level 10 log files. One is a connection try to
>> \\domainname\netlogon, which failes. The second is to \\dcname\netlogon
>> which succeeds.
> A trace is more a tcpdump trace.
>> domain is NOVA (novanetwork.loc), DC is novadc01
>> I have tried from a Win 2008 R2 member server (novawsk05).
> Are you using s3fs ? can you send me your smb.conf ?
> Also can you try to put host msdfs = yes in your [global] section ?
> Matthieu
Hello Matthieu,

with correctly added parameter "host msdfs = yes" the Windows 2008
member server no can successfully access the SYSVOL and NETLOGON shares.
Has there been a change in the samba4 behavior lately ? I am sure that
it worked in the past without this additional entry in smb.conf.

Thank you for your kind help

best regards


More information about the samba-technical mailing list