adding subClassOf if missing

Matthieu Patou mat at
Fri Apr 6 00:08:38 MDT 2012

On 04/04/2012 05:06 PM, Michael Adam wrote:
> Hi Matthieu,
> thanks for taking this further and for your patch.
> I tried it and I got further with it:
> The " /prepareschema" command from exchange 2010 that I ran
> now passed the 75% where it originally failed and then slowed
> down at 98 or 99%, proceeding very very slowly, so that I let it
> run and went to bed... :) I can hence not tell when it finally
> failed again, but the error I am hitting now is this:
> The client sends an ldap modify request to "<ROOT>" with
> empty object and "schemaUpgradeInProgress" set to "1".
> This fails with:
> "unwillingToPerform (00002035: rootdse_modify: unknown attribute to change!)"
> I can show you the capture.
> The same form of request works for schemaUpdateNow, which is
> defined in the samba code, while I could not find anything like
> schemaUpgradeNow.
You meant for schemaUpgradeInProgress ?
According to this it means that we have to relax some checks, I don't 
know if we have the code for relaxing the checks if so it shouldn't be 
too complicated to match 2003 behavior.
If it causes Exchange setup problems we can implement a stub version of 
this but I don't think it will.


Matthieu Patou
Samba Team

More information about the samba-technical mailing list