Samba4 experiences

Dirk Gouders gouders at
Thu Sep 15 08:24:01 MDT 2011


I am using Samba4 in domain controller mode with Samba 3.6.0 as a
fileserver and want to report some experiences and not yet understood
things -- maybe due to my ignorance as a relative beginner:

* Building, installing and provision works like a charm.

* winbind behaves a bit strange on the 3.6 side.  Only the group name is
  not shown correctly, maybe due to a misconfiguration:

  $ id dgouders
  uid=1632(FB5+dgouders) gid=1013(TANGO+none) groups=1013(TANGO+none)

  I already sent a message to samba@ and maybe this problem will be
  solved, soon.

* I accessed LDAP with jxplorer and cannot modify user data; it
  reports that all mandatory attributes must have values.
  I did not look too deep into it but noticed a mandatory attribute
  "nTSecurityDescriptor" that I did not find in the user entry I wanted
  to modify.

* With phpldapadmin the modification of e.g. displayName works, but I
  cannot add an attribute "memberOf".  I am not sure if that would be
  the correct way to manage group membership or if there is a better
  way (except the tools that run under Windows) to do that.

Other open questions of mine I better leave to be solved by continuous
reading ;-)


More information about the samba-technical mailing list