samba4 from BDC to PDC

Daniele Dario d.dario76 at
Tue Oct 25 08:59:26 MDT 2011

On Tue, 2011-10-25 at 09:26 +0200, Michael Wood wrote:
> On 24 October 2011 19:01, Gémes Géza <geza at> wrote:
> > 2011-10-24 16:54 keltezéssel, Daniele Dario írta:
> [...]
> >> So it seems that the reversed zone is present.
> >> Doing a nslookup it gives the right but it won't
> >> work with the direct zone.
> >>
> >> What am I doing wrong?
> >> Daniele.
> >>
> > Recently there was a tread about some updates for samba dlz module to
> > allow dynamic ptr zones:
> >, so
> > maybe you should try a recent git pull?
> I think he's saying that the reverse DNS is working correctly, but the
> forward DNS is not working.
> Anyway, it looks like he has those patches already, since he's running
> 4.0.0alpha18-GIT-3ae478b.
> If you're using the DLZ module, are you still supposed to run samba_dnsupdate?
> Daniele, it looks like bind is not even trying to do anything with the
> forward zone.  Maybe the forward zone is somehow not configured
> properly in Samba.  I haven't tried setting this up, so I don't know
> what might be wrong with it.
Yes, yesterday trying to use the dlz driver bind was able to start and
it seemed that the reverse zone was up but the forward no.

Today if i run named with the dlz driver it says
25-Oct-2011 16:44:14.052 samba_dlz: starting configure
25-Oct-2011 16:44:14.162 zone number of
nodes in database: 0
25-Oct-2011 16:44:14.162 zone loaded
25-Oct-2011 16:44:14.165 samba b9_putrr: unhandled record type 65282
25-Oct-2011 16:44:14.167 zone has 0 SOA
25-Oct-2011 16:44:14.167 samba_dlz: Failed to configure zone
25-Oct-2011 16:44:14.168 load_configuration: bad zone
25-Oct-2011 16:44:14.168 loading configuration: bad zone
25-Oct-2011 16:44:14.168 exiting (due to fatal error)

Looking in dlz_bind9.c, the "unhandled record type" comes from row 189
in b9_format and it seems to me that 65282 can't be a DNS record type.

Is it possible that I have these issues because the SBS AD contains
crap? (I joined the samba4 server to an MS SBS 2003 which was the DC for
my domain so I didn't provision a new domain).


More information about the samba-technical mailing list