rIDNextRID attributes missing

Michael Croes mycroes at gmail.com
Tue Oct 11 00:24:33 MDT 2011

Dear list,

Yesterday I upgraded a Samba 4 alpha 15 install to Samba 4 alpha 17. I
ran samba-tool dbcheck which fixed most of the missing GUIDs, however
when I run it again there's still three entries missing a GUID. These
however can't be updated because they're missing the rIDNextRID
attribute, which is manatory. Besides this being an upgrade from alpha
15 to alpha 17, the data comes from an alpha 13 setup to which I
joined the alpha 15 machine.

Here is the error from samba-tool:
ERROR: missing GUID component for objectCategory in object CN=RID
Set,CN=ADC,OU=Domain Controllers,DC=mijlweg,DC=visser,DC=eu -
Change DN to <GUID=1f7afdf6-547a-4f63-bebc-7238beac8049>;CN=RID-Set,CN=Schema,CN=Configuration,DC=mijlweg,DC=visser,DC=eu?
[y/N/all/none] all
Failed to fix missing GUID on attribute objectCategory : (65,
"objectclass_attrs: at least one mandatory attribute ('rIDNextRID') on
entry 'CN=RID Set,CN=ADC,OU=Domain
Controllers,DC=mijlweg,DC=visser,DC=eu' wasn't specified!")

The same error is repeated for my other two domain controllers.

The LDIF for the object above is the following:
# RID Set, ADC, Domain Controllers, mijlweg.visser.eu
dn: CN=RID Set,CN=ADC,OU=Domain Controllers,DC=mijlweg,DC=visser,DC=eu
objectClass: top
objectClass: rIDSet
cn: RID Set
instanceType: 4
whenCreated: 20101015113027.0Z
uSNCreated: 3668
showInAdvancedViewOnly: TRUE
name: RID Set
objectGUID:: ap1FvfXJTkyIWpnaAUaZtQ==
rIDUsedPool: 0
objectCategory: CN=RID-Set,CN=Schema,CN=Configuration,DC=mijlweg,DC=visser,DC=
whenChanged: 20111007075902.0Z
uSNChanged: 166601
rIDAllocationPool: 262418206878904
distinguishedName: CN=RID Set,CN=ADC,OU=Domain Controllers,DC=mijlweg,DC=visse

Does anyone know any sensible values for rIDNextRid, and probably


More information about the samba-technical mailing list