Inconsistent naming of vfs_read in the VFS Function pointer structure ...
jra at samba.org
Mon Nov 28 14:02:40 MST 2011
On Sat, Nov 26, 2011 at 01:19:10PM -0800, Richard Sharpe wrote:
> Hi folks,
> I came across this:
> /* File operations */
> .open_fn = vfswrap_open,
> .create_file = vfswrap_create_file,
> .close_fn = vfswrap_close,
> .vfs_read = vfswrap_read,
> .pread = vfswrap_pread,
> .write = vfswrap_write,
> .pwrite = vfswrap_pwrite,
> .lseek = vfswrap_lseek,
> Is there any reason that it is vfs_read and not just read?
We should probably do a global rename to _fn for 4.0.0,
to have consistent naming. It breaks all outside tree
Maybe out-of-tree folks can respond ? Would this be
ok for 4.0.0 ?
More information about the samba-technical