DNS update from s3 to s4, working with nsupdate, fails with net ads dns register

Gémes Géza geza at kzsdabas.hu
Fri Nov 4 01:03:43 MDT 2011

2011-11-04 07:57 keltezéssel, Michael Croes írta:
> Hi Geza,
>> Regarding packaging you are right.
>> I just gave up (temporary) to try to build (the latest versions of) all the
>> build and runtime dependencies (which on an git obtained source are
>> included).
> How did you try to package them? Yesterday I was using the debian
> files from samba4 in oneiric (apt-get source samba4) and used that to
> package a newer version. However soon (configure stage) there were
> some dependencies like talloc 2.0.7 which were not met, so I moved on
> to talloc where the source package doesn't seem directly usable
> against a git clone.
> The main issue is to do it once and to do it right, because after that
> anyone can pick up on that and build a newer version, perhaps with
> some minor issues along the way.
>> I'm interested in having stable packages once samba4 stabilizes a bit (~RC1
>> maybe).
> I'm not sure if there's still a target for such a release, but I just
> want to move a step up from where I am now. I want DNS to work
> properly, that leaves me with the option of building a newer samba
> release or going back to the generated named.conf.
> Regards,
> Michael

Basically I've got the source packages from debian unstable (before
experimental) and tried to remove the multiarch modifications (I did the
build on squeeze). When I hit a wall (mean unmet dependency) I've tried
to get newer sources (sometimes from upstream (samba.org)) changed the
version numbers (dch -i) accordingly and started over.



More information about the samba-technical mailing list