Unable to get Samba 4 to pass make quicktest or make test

Preston Kutzner shizzlecash at gmail.com
Wed May 25 15:02:19 MDT 2011

I'm still unable to get tests to pass.  I always get 6 failed tests when
doing a make quicktest, and they're always the same 6 tests.  I wound up
trying to install every missing library (according to
configure.developer output) that I could and still no luck.  Here's one

== samba4.smb.signing on with -k no --signing=off(plugin_s4_dc) ==
command: /home/administrator/samba-master/bin/smbtorture
--configfile=$SMB_CONF_PATH --maximum-runtime=$SELFTEST_MAXTIME
--target=samba4 --basedir=$SELFTEST_TMPDIR --option=torture:progress=no
--format=subunit --option=torture:quick=yes $LISTOPT //$NETBIOSNAME/tmp
-k no --signing=off -U$USERNAME%$PASSWORD base.xcopy $LOADLIST 2>&1 |
/home/administrator/samba-master/selftest/filter-subunit $LISTOPT
--fail-on-empty --prefix="samba4.smb.signing on with -k no --signing=off."
expanded command: /home/administrator/samba-master/bin/smbtorture
--maximum-runtime=1200 --target=samba4
--option=torture:progress=no --format=subunit --option=torture:quick=yes
$LISTOPT //plugindc/tmp -k no --signing=off -UAdministrator%locDCpass1
base.xcopy $LOADLIST 2>&1 |
/home/administrator/samba-master/selftest/filter-subunit $LISTOPT
--fail-on-empty --prefix="samba4.smb.signing on with -k no --signing=off."
ERROR: Testsuite[samba4.smb.signing on with -k no
REASON: Exit code was 1

The 6 errors are all in this block of testing... Best part is, in stdout
it shows "Unknown Error" for these.

On 5/25/11 12:30 PM, diggz2k wrote:
> I ran into some of the same errors. I did a fresh git install of samba 4 on
> redhat 6 server also freshly installed.
> == samba4.smb.signing disabled on with -k no --option=gensec:spengo=no
> --signing=off domain-creds(s3member) ==
> ERROR: Testsuite[samba4.smb.signing disabled on with -k no
> --option=gensec:spengo=no --signing=off domain-creds(s3member)]
> REASON: unable to set up environment s3member - exiting
> --
> View this message in context: http://samba.2283325.n4.nabble.com/Unable-to-get-Samba-4-to-pass-make-quicktest-or-make-test-tp3531338p3550455.html
> Sent from the Samba - samba-technical mailing list archive at Nabble.com.

More information about the samba-technical mailing list